Jump to content
Vivek Bhojan

Y scale Overlapping

Recommended Posts

Hello Friends,

I am using Waveform Chart with multiple Y axis scales. Currently 6 Scales are used and made visible programatically. The Default No of scale is 6.

Now the question is, sometimes when I change the No of scales from minimum to maximum, the scales are overlapped on the plot area. Please see to the attachment.

How to solve this issue.

Thanks

post-18674-0-34800800-1295517384_thumb.j

Share this post


Link to post
Share on other sites

Hello Friends,

I am using Waveform Chart with multiple Y axis scales. Currently 6 Scales are used and made visible programatically. The Default No of scale is 6.

Now the question is, sometimes when I change the No of scales from minimum to maximum, the scales are overlapped on the plot area. Please see to the attachment.

How to solve this issue.

Thanks

I think you can read the Y Scales Positions, sort through them to find where they start and where they end and then set the property "Plot Area Size" and "Plot Area Position" to reduce/move it so that it doesn't overlap with the scales, I haven't tried though.

Good luck.

Share this post


Link to post
Share on other sites

I think you can read the Y Scales Positions, sort through them to find where they start and where they end and then set the property "Plot Area Size" and "Plot Area Position" to reduce/move it so that it doesn't overlap with the scales, I haven't tried though.

Good luck.

LabVIEW Ver 7.1 does not have the option of Plot Area Position.

Share this post


Link to post
Share on other sites

LabVIEW Ver 7.1 does not have the option of Plot Area Position.

I couldn't check because I don't have LV 7.1 installed at the moment but I'm sure that at least you have it for XY Graph, not sure for Waveform Chart...

To check, create a property node on you chart and see at the same path here :

post-7452-0-80561500-1295527620_thumb.jp

Hope this helps

Share this post


Link to post
Share on other sites

Try setting

Advanced >>> Auto Adjust Scales

False

Ben

I have tried this option previously, but the output is something like the image attached. There is a space between the Scales and the Plot Area

post-18674-0-21259300-1295537196_thumb.j

Share this post


Link to post
Share on other sites

May seem like a silly solution.shifty.gif

But can't you put the data on the right hand side so as as the # columns grow; they grow away from the graph rather than towards it? Then you can keep the size fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.