Jump to content
Ano Ano

Omron E5CN via Modbus

Recommended Posts

Hello,

I have a Omron E5CN Temperature controller that I want to use with Labview and Modbus.

I am able to communicate with this controller using Omron's Thermomini software.

MAX is able to validate the and open a session with the device. The controller is connected via a RS232 to USB converter.

I set the controller to modbus but no luck. Maybe its because I dont know how to use the modbus drivers, I havent attempted to use such a device with Labview so I am lost with all this machine codes !

Any advice towards a newbie on how to use this controller with Labview/Modbus?

The programming manual for this controller is here

Share this post


Link to post
Share on other sites

The hardest thing to find is the base Modbus address. No manufacturer seems to put the exact correct address in their manuals, so you'll have to hunt a bit to find the correct base address. Everything after that is offset from the base address.

Share this post


Link to post
Share on other sites

Which mod us library are you using? Is it the free one off ni.com?

From a quick look at the commands you need to be using the register accesses for the data. With the free mod us library I believe you should then be able to send the addresses as the manual suggests, some other implementations require an offset depending on the data you are reading. Generally 3 for read only registers (or variables as the manual calls thru) or 4 for read/write registers so the address for a read only register at address 1 appears as 40001. the addresses appear to be detailed in section 6.

Hopefully this is a starting point to decipher some of the data you are seeing. Let me know what library your using and I may. E able to be a little more specific.

Share this post


Link to post
Share on other sites

I would start with the "echo" command. Once you get that working (i.e. eliminate all the serial configurations and get something tangible back); it should be plain sailing from there.

Share this post


Link to post
Share on other sites

There seems to be a bug in the Modbus CRC calculation vi in the NI library. Replace it with the attached VI that I got from Steve Brooks on the NI website.

MBcrc.vi

  • Like 1

Share this post


Link to post
Share on other sites

Backsaved to LabVIEW 8.0.

MBcrc.LV80.vi

There seems to be a bug in the Modbus CRC calculation vi in the NI library. Replace it with the attached VI that I got from Steve Brooks on the NI website.

Do you know what the changes were in this VI?

Share this post


Link to post
Share on other sites

Sorry, just saw this. I don't remember now, but I checked the CRC generation code and the NI version didn't exactly conform to the ModBUS spec document (Pg 14 & Pg 39):

http://www.modbus.org/docs/Modbus_over_serial_line_V1_02.pdf

Bottom line was: Steve Brooks' version worked with a ModBUS device I was using, and the NI version didn't.

Share this post


Link to post
Share on other sites

Its easiest to use VI Package manager. Just search for Modbus, select the package and install.

image.png.0110c0231f681c36a7486f12e0522c20.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.