Jump to content

Data socket not running in remote PC


piZviZ

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By BeeEyeBye
      I'm trying to read six input registers from a remote device but the software I put together doesn't seem to do much; no errors but no read-backs either.  I'm a beginner, so the answer is probably simple.  The remote device input registers start at 200 hex.  The device uses TCP and the IP address is correct.  My computer communicates well with the remote device through QmodMaster.  Any help you could give would be appreciated.  Thanks, Mike.
       
       
      Modbus Read 01.pdf So far 01.vi
    • By parth
      hello all,
      Firstly I am very new to labview so i apologise in advance if i ask some stupid questions.
      i am running a vi on my rio ( simple analog in/out express vi s) and another vi on my PC. i am communicating between them through shared variable and it works perfectly, only thing is i have to manually run both vi s.
      my question is, is there a simple way to start the vi on myrio from the vi on my PC? 
      PS:- i tried to work with vi server but i failed because of my limited knowledge. 
      any help will be much aprreciated.
      Thanks & Regards,
      Parth
    • By OlivierL
      ShaunR's recent topic on Security reminded me of a situation we explored in the summer and need to revisit at some point. We were looking for a method to protect the communication with a cRIO.
       
      The situation is that we need to communicate between a cRIO and a host on an unsecured network (manufacturing environment.) We concluded that we needed some form of encryption as well as a standard login mechanism but identified that having a single symmetrical key would not provide enough protection (for various reasons and specific use cases.)
       
      Therefore, we looked into SSL and LabVIEW Web Services because it already includes that library and all the security features that we need. We figured out that it would definitely offer the protection required but that would mean rewriting most of existing code to use Web Service instead or establish some for of communication through a new Web Service. Considering the amount of unknown and risks associated with modifying our code, we looked into an alternative and came up with the following scheme:
       

       
      In short, we would use a Web Service for the initial login and create a new symmetrical key which would be passed to the host and to the main application on the target (cRIO) and would be used to encrypt/decrypt all data during the session. This way, we could still program all of our code in LabVIEW and easily download/deploy the services and applications to the Target using NI standard tools but benefit from proper security and only have to add fairly simple wrappers to some sections of our existing code.
       
      I wonder if anyone else has already gone down that route to add protection to an existing application. Would you suggest a different implementation method or an easier path to a similar result? Is there some obvious pitfalls in this approach that we do not see?
    • By Wezarp
      Wezarp allows a software application to be controlled by a remote device such as a tablet, a smartphone or a computer.
       
      The first release of our website www.wezarp.com is now online !!! Wezarp for NI LabVIEW is available... Don't hesitate to download and try the 30-day free trial version !
       
      Here is a video demonstration on how to use Wezarp with NI LabVIEW
       
       
       
    • By FJ_Sanchez
      Hello,
       
      I'm developing an application that uses some PCIe hardware. My daily developing computer is a laptop docked to a dock station. Now, I would like to develop testing my subVIs in the remote desktop that has installed the PCIe hardware. I know I can enable remote debugging, compile and transfer the executable, then execute and connect from my laptop, but this is very inefficient and slow process to test subVIs.
       
      I could install the full development environment in the remote desktop, develop in this machine with remote connection (or even directly on this computer, as it's next to my laptop), but this is not the way I would like to work with every similar project.
       
      Do you have any better approach to debug remote desktop applications? I have heard something about using VI server and executing remote panels or similar, but I have never done such a thing.
       
      Any comment is welcomed.
      Thank you.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.