Jump to content

winMIF and .NET Issues installing LV Build

Recommended Posts

Hi Everyone,

Most of the time I am able to find solutions to my issues just by reading this forum but I wasn't that lucky this time.

So, i got an issue when i'm trying to install my build.

I got the following message: "This distribution is built with an older version of winMIF that is not compatible with .NET 4.6.2 upgrade to 17.0"

When googling this error message or even "winMIF" i can't find anything that match my request :(
I tried to uninstall the .NET framework and then reinstall the 4.0 (and 3.5) and I got the same issue. (Exactly the same error even if it's .NET 4.0 or 3.5 ...)

The computer used to build is a Win7Pro with Labview 16.
The target computer is a WES7 (but I got the same issue on my dev computer ...)

In advance thank you, 


Link to comment

Thank you Scottish Moose, you were right about the additionnal packages.

So, quick update :
I made a new build from scratch and let Labview manage the additional installers. That way I was able to install the build.
But when manually adding NI MAX 16, I'm back to the issue explained before...

I temporarely fixed this by downloading NI System Configuration package (16.1) and installing it manually on the target computer. 

The good point is that I'm now able to do the tests I wanted to do yesterday. No more 'emergency' :) ...
Bad point is that my problem is still there. Because I need an installer with NI MAX ... (But of course if there's no solution I'll install it manually...)
Is there any know issues with NI MAX / dotNet 4.6.2 / WES7 / LV16 ??

I will continue my investigations and keep you up to date with my progress.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By bartek618
      I know how to run .Net executable by MainWindow() constructor but I have some resources defined in App.xaml and MainWindow() doesn't run without them. How to run application starting with App() constructor? Also I need to pass some parameters into MainWindow().
    • By Chris Cilino
      In order to quickly and efficiently prepare source for distribution, a build system was necessary to abstract away the conversion of source into the different types of deliverables (VIPackages, Executables, dlls, ect) as well as abstract away the build order of our software hierarchy.
      Many have undertaken to solve this problem. I don't claim to have created a silver bullet. But I do hope that the system I've put together (and am releasing as open source) will act as a starting point for you to extend and customize to meet your needs. I've endeavored to employ good software development principles including separation of concerns, and the SMoRES principles.
      I'll be the first to volunteer that it isn't perfect and as always, our best software is constantly a work in progress. However, I believe the build system is at a stage to be at least moderately helpful to a handful of people in our community. 
      The Application's UI
      The UI is designed to guide someone through the build process, allowing them to select what components or exports they would like to build, if and how they would like to be notified about the build, auto submission options, and source code control. I've attached a small video titled "Build UI Demo.mp4" below.
      UML and APIs
      All UML and API documentation are included in the Word document per released zip file
      Software Requirements
      LabVIEW 2017
      NI Application Builder
      VI Package Manager Pro
      Other dependencies are listed in the Instructions per zip file.
      UML Overview
      As of 1.4.0-58 the UML looks like:

      Build UI Demo.mp4
      Release Notes
      1.4.0-123 (Component Builder 1.4.0-123.zip)
      Added new NI Package Manager API Added new NI Package Manager BuildSpec Utils  Added procedure and documentation for the component template and its anatomy  
      1.4.0-113 (Component Builder 1.4.0-113.zip)
      Added documentation for the SCC API  
      1.4.0-111 (Component Builder 1.4.0-111.zip)
      1.4.0-99 (Component Builder 1.4.0-99.zip)
      Added a few new P4 API functions allowing the creation of a session if a user is already logged it.  Added Log in and log out tests to the test suite.  Adding new function to tag all p4 paths in a label with the label. Resolving the input path to a p4 depot path Adding quotes around p4 paths.
      1.4.0-91 (Component Builder 1.4.0-91.zip)
      The refactor of the LabVIEW SCC API is complete and the build process is linked to the new install location. The LabVIEW SCC API can now be used independently of the Component Build process.  I've included a test suite for the P4 implementation of the SCC API. It assumes that you have checked in the two files in the "Build Instructions\LabVIEW SCC API\Test Suite\Tests\Test Dir" into perforce.  
      1.4.0-85 (Component Builder 1.4.0-85.zip)
      This is a major refactor in the SCC API. I've modeled the p4 label with a new api. This release is primarily as an intermediary release. I intend on breaking SCC out of the component builder into its own separate component in the next release. 1.4.0-81 (Component Builder 1.4.0-81.zip)
      Created a "proxy" api for VI Package manager interactions. Sometimes the VI Package manager api would hang. So I now call by reference and will kill and restart VIPM if it doesn't respond in time.   
      1.4.0-75 (Component Builder 1.4.0-75.zip )
      Fixed reference counting for executable builds.   
      1.4.0-73 (Component Builder 1.4.0-73.zip)
      In the case where a user has specifically unchecked "auto increment", the build process will auto increment the build. Builds must be auto incremented.  I've released a new build of the container that has a minor bug fix. Added file utility tools to aid with using "net use" to move and copy files across the network.  
      1.4.0-59 (Component Builder 1.4.0-59.zip)
      Minor spelling error in component template: "componet". Added documentation for the Custom Install Step Launcher. Added build instructions for Custom Install Step Launcher.  
      1.4.0-58 (Component_Builder_1.4.0-58.zip)
      Added the ability to export NI-Source Distributions, NI-Executables, NI-Insatllers, and NSIS Installers Released a template component that exports an NI Package and VI Package including step by step instructions Released "Custom Install Step Launcher" to execute VIs as pre install, post install and post install all actions for NI Packages. Released comprehensive documentation included in the zip file. Component_Builder_5_31_2018.zip
    • By William Hofmeister
      I need to access Aerotech A3200 data with LabView. The Digital Scope in the A3200 software has the capability to record data at 1kHz for 8 seconds in dedicated batches. We use LabView for all functions surrounding the motion control and have the Aerotech LabView package. Using the LabView vis we can only access data a single data point per call and I don't see how to set up a FIFO to Windows LabView. Someone must have looked at this problem lately. Can anyone steer me in the right direction?  Thanks!!
    • By LogMAN
      So this just happened to me and I'm quite confused by it. As it turns out, the .NET Constructor Node not only provides terminals for error in, error out and the reference, but actually two more "hidden" terminals:

      Notice: I left the error terminals untouched and none of the wires are connected (try it yourself). This never occurred to me. Only now, while hunting a null reference exception I found the constructor node looked "off", like this:

      The strange part is that the terminal doesn't actually carry the reference (which is why I receive the null exception). It only specifies the type. The upper left terminal is a void type input, so the wire is always broken.
      Does anyone know why these extra terminals exist? They don't seem to be part of the specification as far as I can tell.
      Any fancy things we can do with this?
    • By ensegre
      This is a DSC module question: has anybody here experience with building standalone executables which include shared variables bound to DSC modbus i/o servers? I have an issue with deployment, possibly related to licensing. I posted on the dark side, but haven't got feedback yet.
      TIA, Enrico
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.