Jump to content

Bugs are now "res non grata" in LabVIEW


Recommended Posts

Apparently, NI has changed there Support's website.

- you cannot write a description of a problem. You choose your preferred communication means and write a one-liner topic, press "Send", and... wait to be contacted by NI.

- you cannot provide example files when filing a bug "report". You can only provide "steps to reproduce".

I guess there are so few bugs nowadays in LabVIEW that NI figured they could get rid of the whole obsolete process of filing detailed bug reports.

  • Confused 1
Link to post

Oh man and I was just touting NI support as being one of the few "fine" parts of NI.com.  Never mind.

I'm really confused and I think the report a bug feature is worst than you made it sound.  So I got there and it says "In which product did you encounter the bug".  It asks for a Serial Number.  I enter "LabVIEW" or "LabVIEW 2020" and it didn't work.  So I tried entering the serial number of my hardware or model number and that didn't work.  I think I'm supposed to put in the serial number of my LabVIEW license, but I'm on a disconnected license from a VLM so I have no serial.  Am I not allowed to report bugs?  I'm thinking I'll make another post on the dark side to try to get some kind of answers.

EDIT: Okay it seems I can find my license number but I need to dig into the quote to find it.  I couldn't find it anywhere else.

Link to post

I can confirm, it expects you LabVIEW License number.

I've recently created a few  SRQ via ni.com/ask

The interface and the process have changed a bit, but I could describe my issue and attach files (max report amd a zip containing code).

Link to post
1 hour ago, Antoine Chalons said:

I can confirm, it expects you LabVIEW License number.

I've recently created a few  SRQ via ni.com/ask

The interface and the process have changed a bit, but I could describe my issue and attach files (max report amd a zip containing code).

Try again. This doesn't work anymore. I received an email from NI, which I answered with an attachment, but this ability is gone on the website.

Regarding S/N, you don't need one (this is specifically stated on the submission page).

Link to post

It's getting better. First of all, gone are the annoying automatic acknowledgment emails. Not sure whether this is good or bad.

After I received an email from a NI engineer asking me for details, I sent a demo VI and a test file (which I would have otherwise uploaded on the reporting site) attached to my email, only to receive the following after a few hours:

Quote

I hope you are having a great day. This is XXXX from NI, Technical Support Engineering.

Based on your report, can you send me please the demo VI you mentioned in the description? Based on that I could move forward, reproduce it and fill the bug. I do apologize if you already attached that, but I could find it on the case files

Is this bug affecting your projects or you just wanted to report it? Because if it is unexpected behavior, the fix will depend on R&D priorities.
 

So, either NI's email system strips any attachments from incoming emails, or the engineer doesn't understand English since I responded (and duly attached the two files):

Quote

Hi.

 
there used to be a way to upload files to document a bug report. Is this all gone by the wayside?
In any case, I am attaching an example code  (LV 2019 SP1) and image.
Instructions are on the VI's panel.
Thanks.

The last sentence is also worth its weight of peanuts...

Obviously, I am reporting bugs because I get a kick out of annoying NI!

Link to post

I've used the NI forum to report bugs, and  got a few CARs out of that channel. Does that still work?

  

7 hours ago, Antoine Chalons said:

it expects you LabVIEW License number.

So what happens with customers who have a Development Suite, where a single serial number is used to activate a variety of different products?

Link to post
6 hours ago, JKSH said:

 

So what happens with customers who have a Development Suite, where a single serial number is used to activate a variety of different products?

Well that's my case as well, and it worked with my (what we use to call) DSRL license number.

 

As for uploading files, I created a srq last week and could upload files. Maybe things have changed since.

If I go to my existing SRQs I can still upload files, I just tried, it worked.

 

What I'm suspecting is that based on your account (partner / not partner / company, etc..) NI filters and gives you a different feature set for creating your SRQ, that wouldn't shock me.

Edited by Antoine Chalons
Link to post

I got confirmation that the attachments in my email were stripped off, and told that I could do exactly what Antoine just mentioned above.

I am positive though that I was not offered this option when submitting the bug, which is a change compared to the past system.

And again, there is no need for a S/N (a SSC number doesn't work).

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.