Jump to content

Search the Community

Showing results for tags 'event'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Software & Hardware Discussions
    • LabVIEW Community Edition
    • LabVIEW General
    • LabVIEW (By Category)
    • Hardware
  • Resources
    • LabVIEW Getting Started
    • GCentral
    • Code Repository (Certified)
    • LAVA Code on LabVIEW Tools Network
    • Code In-Development
    • OpenG
  • Community
    • LAVA Lounge
    • LabVIEW Feedback for NI
    • LabVIEW Ecosystem
  • LAVA Site Related
    • Site Feedback & Support
    • Wiki Help

Categories

  • *Uncertified*
  • LabVIEW Tools Network Certified
  • LabVIEW API
    • VI Scripting
    • JKI Right-Click Framework Plugins
    • Quick Drop Plugins
    • XNodes
  • General
  • User Interface
    • X-Controls
  • LabVIEW IDE
    • Custom Probes
  • LabVIEW OOP
  • Database & File IO
  • Machine Vision & Imaging
  • Remote Control, Monitoring and the Internet
  • Hardware

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Personal Website


Company Website


Twitter Name


LinkedIn Profile


Facebook Page


Location


Interests

Found 11 results

  1. My code watches for an event where my Toshiba USB stick is unplugged. If the event does not occur within 30 secs, the code times out. However, in the case that there is no disconnection of the USB stick (no event generated), I can't end the program before the timeout period of 30 sec. Is there a way to end the program before the timeout period? Any help is appreciated. Thanks in advance! WMI_USBStorage_Event_withDeviceIDandTimeOut.vi
  2. Hello! I am running a system with GigE camera with NI framegrabber in continuous acquisition mode - in which I change some attributes every now and then. So far I have been using following scheme to assert I am getting correct image after attribute change: change attribute read "Last buffer number" property -> n run IMAQdx get image.vi set to "buffer' and parameter n+2 (+2 being due to the fact that i assumed attribute change arrives to camere during running exposure that will be unaffected by attribute change - hence i needed to discard "next" buffer) Unfor
  3. Hi I am writing an application to update the numeric value given user's input value and depending on the user's input value the program checks if it is greater than 10 if it is greater than 10 then the program waits for 1 second and then will have a popup message says "true". My intention was to call the conditional check, printing true every one second if the user's input value is greater than 10; in other words, the case structure was to be called regardless of the event structure in the same loop infinitely. But it doesn't seem to work the way I expected. Unless there is user
  4. Hello, I searched within this site and via Google for any related queries. Couldn't find any. Hence this post... Example of Situation: I configured an I8 Numeric with non-default limits in its 'Properties >> Data Entry' window... Minimum of -2 (coerced); Maximum of 2 (coerced). I set up a simple event that looks for 'Value Change' of this Numeric. Expectation: No matter what the 'Increment' value and 'Response to value outside limits' are set to, the 'Value Change' must NOT trigger if the numeric is already at the limit and cannot be changed further. To explain, If current
  5. I have been trying to understand what's going on with my tree control and I'd like to share this with the community to see if somebody has seen this behavior before. Maybe there is something obvious that I am not seeing... I attached the VI (LV2011) with instructions inside (will take you 20s to perform the experiment, I dismantled the VI to its bare minimum). Please don't comment on the overall architecture (state machine...) since I modified the VI just for the sake of posting it here and removed all advanced features. Long story short, after programmatically modifying the value of t
  6. Hi all, new to Lava, so (kindly) let me know if I screwed up my post I have a multi-user web application controlled by a LV web service. I keep track of all the users through the web service > sessions VI's. This is pretty cool and works really great. I can give each user different levels of authentication, force them to use SSL, track where they go and when throughout the website, etc. Now what I'd like to do is keep track of when their session expires. Obviously I can provide a "Logout" link on the client-side which ultimately calls the "Destroy Session" VI, but I can't en
  7. Hi all, Any thoughts on the simplest way to trigger a LabVIEW event using an external script in Windows? I want to be able to poke my LabVIEW application and kick off a predefined code block. No need to pass any information/message. I'm looking for something very passive, unlike, for example, a listening TCP socket. Thanks!
  8. Hello Lava-people Is it possible to have labview generate an event when a control is deselected? I have a search bar in my application. When the user selects the string-control, a connection to a database is established. When the user is done searching the database, and selects a new control, I would like to destroy the reference to the database thus freeing up the database. Is this possible? Hope you can help me. /Jørgen
  9. Hi all, every 10 minutes we are logging data by a LabVIEW 8.2.1 application from a remote control in a 24/7 process. Timing is realized by a timeout in a event structure. This worked well for several years. Some months ago our IT moved the application and RunTimeEngine to a VMware machine. Since that time we have a second data logging within 10 minutes. As I am not familiar with VMware I have no clue what happens. Any ideas appreciated. Thanks in advance Manfred
  10. I want to add an event case to handle the browser back button from a mouse (or keyboard). This would be for a user interface and not in a browser. Are these buttons only reconigized by javascript? The event structure seem to only catch mouse buttons 1,2,3.
  11. I'm trying to create some monitoring software that can monitor 20-30 clones. Each clone does the reading and tracking of a particular unit. I have a central VI that should launch and kill the various clones. I know it's nothing that hasn't been done before and it seems simple enough, but I've been having problems with "Error Code 1: Generate User Event in (name of VI)" which apparently means the Event isn't firing properly. I'm not seeing the error in this set of VIs though, which is good and bad because a) it works but b) I don't know what the problem is when it doesn't. I'm fairly positive
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.