Jump to content

Red X on Palette VI's

Recommended Posts

Has anyone see this and know why it occurs?

Using LV2010.

Tried the menu's in the lvlib and the lvclass.

The examples show up ok (assuming because they are outside the library).

Default palette set for the lvclass to dir.mnu.

The vi's drop out of the palette ok...they just have the X on them.

I am using the lvlib because I am giving the option to build a packed library. It is really slow and hogs a bunch of memory in the development environment though when I am working with it so I just went to a source distribution. Might try 2011 to see if they optomized it.




Link to comment

Thanks for the information guys. I guess I should have searched Red crosses and not Red X. It was late, sorry.

I will try it in 2011. Maybe resave all of the menu files when I do incase they fixed it in the way they are saving the menu files themselves. I'll let you know if resaving works.

Thanks again.

Link to comment

By fixed, we mean the symbols showing up incorrectly. The X will still show up sometimes for correct reasons.

The X means that you do not have the license file so this VI will be broken.

I *think* it can also show up in right-click palettes when the VI you clicked on does not have access scope privileges to use the VI in the palettes. So if there's a private scope subVI in your palettes, you'll see the X when you pop up on a VI that is outside the library that owns that subVI. I say "think" because the feature was proposed that way, but I haven't kept up to know if it actually was implemented.

I can't explain why mje is still seeing a problem. Can someone post this on the ni.com forums so an AE can dig into it?

Link to comment


The X marks are annoying, but as long as the palettes work I don't mind much. Odd.

Definitely not fixed though. LV2011, these are public methods of a public class in an lvlib:

I'm not seeing the Xs:


I'm pretty sure the fix didn't require any action on your part. I noticed the package you attached here didn't include any palettes. I wonder what happens if you don't include the palette files. The CAR mentioned above (185059) included a palette in the example code.

Link to comment

Hehe, I forgot I posted that preview. You're right, no palettes included. My current library is version 2.1 (despite that the palette says "2.0", oops file that one under "bug"). This version was compiled with 2011 as it uses the new start async call nodes. I'll get an export generated tonight and post it to see if the problem can be reproduced.

I really ought to finish that library one of these days...

Does it matter how the palettes were added to LabVIEW? All I ever do is edit the set manually via the advanced menu option and add the existing mnu file. Too busy (lazy) to create an installer for the library.

Link to comment

Recompiling in 2011 worked. The only vi with a Red X now is the property node which is a broken vi because I don't have the class going into it(setup for place vi contents).


That's cool.

Did you test just opening the <LabVIEW 2011 code in LabVIEW 2011 without compiling in LabVIEW 2011 first?

What was the result?



Link to comment

I did however realize that the red X on the property node vi was because I had made it a private function.

Cool, yep, its meant to do that.

I will try it without compiling, but will probably do it tonight.

Cool, I will try to fire up 2011 later on and check too.

Link to comment

I'd say no, I still see the red marks on my system with some of the menus from the library I posted. I can't say I understand why some have x marks and some don't. My Application palette does not have the glyphs, but the MessagePump one does. Both are in the same library, and the VIs have the same scope. There is no license associated with the library.


I will post this to the ni.com soon, just giving it a bit to see if it resolves over here first.

Link to comment

Cool, yep, its meant to do that.

Cool, I will try to fire up 2011 later on and check too.

OK... so at the end of all this... is the behavior now what everyone would call "correct"?

If yes, does it match the documentation?

If no, what still needs tweaking?

Finally got around to checking it without recompile and it works as expected for me. Private function has an X and the public functions do not.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.