Jump to content
Gan Uesli Starling

Tab showing after open, but prior to run

Recommended Posts

So I have a multi-tab GUI. But for some reason, on load before run, it doesn't display the tab that was showing on save. It shows a tab which I don't want to be showing instead. On run, it starts with the right tab. Then saving and closing with that tab showing, on re-open (before run) it still shows a tab I don't want. How can I influence that?

On top is the tab I want to show on open before run. At bottom is the tab that shows instead. You see my problem...

tab_right.png

tab_wrong.png

Edited by Gan Uesli Starling
clarification

Share this post


Link to post
Share on other sites

It sounds like you have made the 'Service Use Only' tab the default value for the Tab control. Select the 'Manual Adjust' tab, right click on the tab, and from the short-cut menu select Data Operations>>Make Current Value Default.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Gan Uesli Starling
      On my Front Panel I have mostly buttons. Buttons and a single Input box for typing serial number. That single Input box feels like a stumbling block to users who habitually TAB their way from widget to widget. They stumble because, after typing the serial number into the box, they can't TAB their way out. Instead (of course, to my way of thinking) the Input box accepts the TAB as a character (rather than interpret it as a command). It bothers some (unreasonably, to my way of thinking) that they should have to press Enter, rather than TAB, to exit that box. What they want is to press TAB and have the data be entered, plus take them to the next widget (a Button).
      So my question here is, can I make that happen for them? Can I make TAB perform like Enter while inside an Input box? Or should I just insist they get used to Input boxes requiring Enter?
    • By piZviZ
      In my project i have 2 task
       
      (1).Read data of sensor (attached to arduino board) serially  and display on LabVIEW.
      (2).Control output(just ON-OFF) pins of arduino using LabVIEW.
       
       
      So,for that i am using TAB in labview.created 2 TAB called Oscillospe and Input.
       
      If i first start Oscilloscope it work well.
      But when i come to Oscilloscope tab after using Input tab.
       
      It gives Time out error (VISA read)
       
      If i am executing in Highlight mode it works well
       
      tab--event.vi
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.