Jump to content

Need help with measure AC current


Thang Nguyen
Go to solution Solved by machyaer,

Recommended Posts

I am working on a project with requirement of measuring current. The system includes both the AC current transducer CR4211-15 (Input 0/15AAC, Output 0/10VDC) and a Fluke i5S (Input 0.01/5AAC, Output 400mV/A).

 

I use cDAQ9184 with NI-9205. I tested with a light and using MAX to monitor the signal but the signal really noise from the AC transducer and clamp. 

Please take a look at the pics I attached which is the screenshot from MAX.

 

I hope anyone with exp can give me a help.

 

Thank you!

Thang Nguyen

post-7703-0-51394700-1380053135_thumb.pn

post-7703-0-13505500-1380053137_thumb.pn

Link to post

Hello Thang,

 

if you are testing your system with a 220V lamp to have a not-to-low signal on the transducer you need a 1kW lamp otherwise the measure will be lesser than the 30% of the fullscale of the transducer or, at least, a 150W lamp as suggested Phillip...

 

Check the wiring of the transducer and test its output by using a normal voltmeter... finally check the connection with your card and the settings in MAX....

from the last image you send I saw a differential input settled... isn't it?

 

Max

Link to post

Max,

Yes, it's a differential input.

Since I have just accessed to a scope, and I tested with my current lamp + an industry fan, I got a really good DC signal from transducer. But from Max, I got the same level of peak but the signal still goes to zero as in my first picture. Somehow I get a noise from my card.

 

Regards,
Thang Nguyen

Edited by Thang Nguyen
Link to post

very strange behaviour...

 

did you check that the 2 inputs you used are the correct ones? (i.e. AI0 - AI8)

 

did you try using another input channel? (e.g. AI1 - AI9)

 

did you groung the COM pin of the board?

 

Max

 

PS: If it is possible try using a RSE connection connecting just the AI0 and the other side to GND and see the difference

Edited by machyaer
Link to post

Great :thumbup1: ! one of the problem is solved...

 

for the Fluke I don't think that the output is in AC... I suppose that is in DC and with the data you wrote 0,4V for each Ampere of measurement (e.g. if the reading is 2A the output should be 0.8V) so I think that the same connection of the transducer with a fullscale limited at 2V will be sufficient...

 

let me know

 

Max

Edited by machyaer
Link to post

Max,

I tried with RSE but it didn't work.

 

 

Great :thumbup1: ! one of the problem is solved...

 

for the Fluke I don't think that the output is in AC... I suppose that is in DC and with the data you wrote 0,4V for each Ampere of measurement (e.g. if the reading is 2A the output should be 0.8V) so I think that the same connection of the transducer with a fullscale limited at 2V will be sufficient...

 

let me know

 

Max

 

post-7703-0-07779300-1380130504_thumb.pn

Link to post
  • Solution

ok, I checked on the fluke website for the manual of this clamp... and it seems that the output is in AC  :blink: ...

 

so if you are a 50Hz power supply connected to you lamp you should have  the same sinusoidal signal on the reading... always referred to the GND...

 

Did you connect the shield of the bnc cable of the clamp to the gnd of the system? (where the RSE reference should also be)

 

Max

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Gan Uesli Starling
      I have a LabVIEW program, which when operating with simulated input data is blazing fast during mock-up. As soon as I hooked into a real cDAQ on Windows, however, the update speed fell off to 4 seconds. That's awful slow. I don't really have a whole lot of channels. I have read tasks for Volts of maybe 5 channels, write tasks for both On./Off for maybe 10 channels (simultaneous) and write tasks for 4-20mA of only 5 channels. How may I improve on that? Is it maybe a priority issue in Windows or to do with USB? What? How to improve? Thanks in advance.
    • By Manudelavega
      Hi, I have contacted NI sales services but it's a great frustration as usual, so I will try to get some support here
       
      Basically for a project I need 2 CAN ports and I decided to go with XNET and Compact DAQ. I have 2 solutions I try to choose from:
       
      Solution 1 --> One 4-slot chassis with 2 NI-9862 modules (one port per module)
      Solution 2 --> One 1-slot chassis with 1 NI-9860 module (this module has 2 ports)
       
      I am confident that solution 1 will work well since I already had a project in the past with one 4-slot chassis (cDAQ-9174) and one NI-9862 module. But going with solution 2 will allow me to cut cost significantly. I just want to make sure it will be absolutely seamless and transparent for the software. Does anybody have experience with the NI-9860? Can it be considered as the equivalent of 2x NI-9862 as far as the software is concerned (LabVIEW driver) or does it remove some performance/flexibility/other?
       
      Thanks!
    • By volatile
      Lets pretend I wanted to simulate a solar panel using a cDAQ, a programmable power supply and a light sensor. Id have to measure the voltage from the light sensor and the PSUs current, use those values to find the respective operating point on my light/voltage/current-curve and update the PSUs settings. Lets also say I wanted to do this for multiple systems in parallel, all connected to 1 analog input and 1 analog output module in 1 cDAQ.
      What would be the best way to achieve the quickest response time? Simply reading and writing single samples seams to be pretty slow (though I can encapsulate everything neatly this way).
      Is there a better way?
    • By FJ_Sanchez
      Hello,
       
      I've been struggling with this problem for months now... I want to use a cDAQ9171+NI-9234 with an Advantech PC (AIMB-580). I have 3 computers like this and all with the same problem. I plug the USB cDAQ-9171, Windows detect the device and loads the proper driver (cDAQ-9171), it is displayed in MAX but self-test or reset always fails with error. At the same time, NI Devive Loader service hangs up. If I try to restart or stop this service it cannot complete the operation, the only way to finish this operation is to unplug the usb cable from the PC, then the service restarts correctly. Additionally the windows' event logger shows the next error message:
       
       
      or
       
       
      In one PC I re-installed Windows, installed DAQmx 14 and the problem was still there, this is with a Windows fresh-install... After this, I removed DAQmx 14 and installed DAQmx 9.8 (supplied in CD) and the it worked!!! I upgraded to DAQmx 9.9 and it was still working, so I stoped there as it was all I needed (9.8 has some bugs with NI-9234 that 9.9 solves).
       
      One thing to note, when it works, Windows first install cDAQ-9171 driver, but then inmediatly it changes to USB flash firmware updater, after this it returns again to load cDAQ-9171 and detects the NI-9134. When it don't work it only installs the cDAQ-9171 and doesn't load anything more...
       
      I tried in a second PC to repeat the process, but I have been not able to repeat the success, only the fail... I get the same error every time I plug the USB and I have not idea of what else try... I have disabled UAC, cleared the MAX data, reinstall windows 2 times, tried with DAQmx 9.8, 9.9 and 14. Forced USB flash firmware updater as Windows driver, changed BIOS settings (disable hyper-threading, VT extensions, USB legacy, etc.). I am almost sure that it is some kind of weird incompatibility or similar, the thing is that NI device loader always hangs-up. In the next days I'm going to try to copy the same exact configuration of BIOS from the working PC, just to be sure.
       
      Any recommendation?
    • By rifenbug
      I am designing a new project and I need to know if I can get away with purchasing 2 9181 chassis instead of one 9188 chassis.  I will be using a 9213 for thermocouple readings and a 9208 for 4-20mA current readings.  The signals dont nee to be syncronized and will only have to read once a minute or so.  My question is whether or not I can read the signals from both chassis at the same time through MAX and easily imput into a LabVIEW program.  

       

      I am currently using a single 9188 to accomplish the same tasks at a different location but am trying to cut costs on the next project.  The 9184 is not an option due to the software version I am running. 

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.