Jump to content

How do I de-register a Windows WMI Event watcher before timeout in LV?


Recommended Posts

My code watches for an event where my Toshiba USB stick is unplugged. If the event does not occur within 30 secs, the code times out. However, in the case that there is no disconnection of the USB stick (no event generated), I can't end the program before the timeout period of 30 sec. Is there a way to end the program before the timeout period? Any help is appreciated. Thanks in advance!image.png.a42902121b7a6054058ea75c5f54030a.png

WMI_USBStorage_Event_withDeviceIDandTimeOut.vi

Link to post
Share on other sites

Welcome to Lava!

There is no way to intercept WaitForNextEvent, other than generating the event it is waiting for or the timeout occurring. It is, however, possible to handle the event directly in LabVIEW. Are you familiar with .NET Event Callbacks?

Use the Register Event Callback function to execute a callback VI to generate a user event for an Event Structure. The event structure can then take care of the timeout as well as other events that may end execution prematurely. Here is an example. For simplicity reasons I didn't include error handling and the callback VI, but you should be able to work the rest out from here.

1544210445_EventWIthDevice.png.60a809936141ce94eebe144d55b54a10.png

Disclaimer: I haven't tested this, but I'm certain it will do what you want.

Edited by LogMAN
  • Like 2
Link to post
Share on other sites

Thanks for taking a stab at this, LogMAN!

Unfortunately, that did not work. Looks like there is something special about 'WaitForNextEvent' that recognizes system level WMI events that LabVIEW is not able to see. I'm no WMI expert, but I looked at this in terms of dataflow by highlighting execution on the block diagram. It appears that the data just flows through 'Reg Event Callback' node without waiting for the event as soon as the program is run.

I'm going to assume that there is a rather low probability of you having a Toshiba USB stick :)

I modified the code to where it detects the launch of Notepad. This way, you could test it on your system if interested.

Again, thank you for your help.

 

 

WMI_NotepadLaunchEvent_withTimeOut.vi

Edited by Mode_Locked
Link to post
Share on other sites
8 hours ago, Mode_Locked said:

Thanks for taking a stab at this, LogMAN!

Unfortunately, that did not work. Looks like there is something special about 'WaitForNextEvent' that recognizes system level WMI events that LabVIEW is not able to see. I'm no WMI expert, but I looked at this in terms of dataflow by highlighting execution on the block diagram. It appears that the data just flows through 'Reg Event Callback' node without waiting for the event as soon as the program is run.

I'm going to assume that there is a rather low probability of you having a Toshiba USB stick :)

I modified the code to where it detects the launch of Notepad. This way, you could test it on your system if interested.

Again, thank you for your help.

 

 

WMI_NotepadLaunchEvent_withTimeOut.vi 13.21 kB · 1 download

Reg Event Callback is not the thing that waits, it is (as the name implies) merely the registration. It should return immediately. Did you create the callback VI?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By _Mike_
      Hello!
      I am running a system with GigE camera with NI framegrabber  in continuous acquisition mode - in which I change some attributes every now and then.
      So far I have been using following scheme to assert I am getting correct image after attribute change:
      change attribute read "Last buffer number" property -> n run IMAQdx get image.vi set to "buffer' and parameter n+2 (+2 being due to the fact that i assumed attribute change arrives to camere during running exposure that will be unaffected by attribute change - hence i needed to discard "next" buffer) Unfortunately I still every now and then acquired image that obviously was aquired with previous attributes (e.g. I've dramatically increased.decreased exposure rate, while acquired image was very similar to previously acquired one). Guessing that it may have something to do with buffers I have increased "magic number" from +2 to +3. It indeed helped, but after longer usage I have discovered, that it only reduced the frequency of the error.
      Hence I needed to design more "bulletproof" solution that will satisfy my timing requirements (stoping and starting acquisition is out of question as it takes more than 100ms what is unacceptable for me)
      I would like to:
      change attribute acquire information from camera that will allow me to fetch image acquired with changed attribute For such purpose I have discovered IMAQdx events - especially "Attribute updated" and "frameDone". Unfortunately, I could not find any detailed documentation about those functions. Therefore I would like to ask you for help to determine when 'Attribute updated" is triggered. Is it when:
      driver receives the command and pushes it to camera? (pretty useless for me as I cannot relate it to any particular exposure) camera confirms getting it (then assuming it arrives during an ongoing exposure, I'll discard "next' image and expect second next to be correct camera confirms applying it (then I assume that next image should be obtained with correct settings) camera confirms it managed to acquire a frame with new parameter (pretty unlikely scenario - but the i'd expect correct image to reside in "last" buffer) Could you help me determine which case is true? Also should I be concerned about the fact that there may be a frame "in transition" between camera and IMAQdx driver which will desynchronize my efforts here?
       
    • By takanoha
      Hi
      I am writing an application to update the numeric value given user's input value and depending on the user's input value the program checks if it is greater than 10 if it is greater than 10 then the program waits for 1 second and then will have a popup message says "true".
      My intention was to call the conditional check, printing true every one second if the user's input value is greater than 10; in other words, the case structure was to be called regardless of the event structure in the same loop infinitely.
      But it doesn't seem to work the way I expected. Unless there is user's new input value, getting into the event structure, the program doesn't get to the case structure even though the case structure is in a loop.
      Is there any way to call the case structure not dependent to the event structure but I want to use a shift register for the numerical value and also having an event structure and a case structure in parallel ? 
      Thank you.
       
       


      test.vi
    • By dhakkan
      Hello,
       
      I searched within this site and via Google for any related queries. Couldn't find any. Hence this post...
       
      Example of Situation:
      I configured an I8 Numeric with non-default limits in its 'Properties >> Data Entry' window...
      Minimum of -2 (coerced); Maximum of 2 (coerced). I set up a simple event that looks for 'Value Change' of this Numeric.
       
      Expectation:
      No matter what the 'Increment' value and 'Response to value outside limits' are set to, the 'Value Change' must NOT trigger if the numeric is already at the limit and cannot be changed further. To explain, If current value of Numeric is 2 and I try to increment it, its value must remain at 2 and no event should be triggered. Similarly, with current value of Numeric at -2, if I try to decrement it, its value must remain at -2 and no event should be triggered.
       
      What I found was that the value does remain at the limit, but an event is still triggered when the 'Increment' setting is non-zero. Is this normal behavior?
       
      Test Numeric Event Triggering.vi coded in LV2014
    • By Manudelavega
      I have been trying to understand what's going on with my tree control and I'd like to share this with the community to see if somebody has seen this behavior before. Maybe there is something obvious that I am not seeing...
       
      I attached the VI (LV2011) with instructions inside (will take you 20s to perform the experiment, I dismantled the VI to its bare minimum). Please don't comment on the overall architecture (state machine...) since I modified the VI just for the sake of posting it here and removed all advanced features.
       
      Long story short, after programmatically modifying the value of the tree, I modify its value a second time by clicking directly on one of the tree items. I then expect the NewVal value given through the left node of the value change event case to match the value of the tree terminal. Depending on the code that first modified the value programmatically, sometimes this expectation is met and sometimes it isn't. Run the code, it's easier to understand that way...
       
      Thanks for your feedback!
      Tree value issue.vi
    • By Roryriffic
      Hi all,
       
      new to Lava, so (kindly) let me know if I screwed up my post
       
      I have a multi-user web application controlled by a LV web service.  I keep track of all the users through the web service > sessions VI's.  This is pretty cool and works really great. I can give each user different levels of authentication, force them to use SSL, track where they go and when throughout the website, etc.
       
      Now what I'd like to do is keep track of when their session expires.  Obviously I can provide a "Logout" link on the client-side which ultimately calls the "Destroy Session" VI, but I can't ensure that all clients will click the link to log out (e.g. how many times do you really sign out of gmail verse just close the browser?!)
       
      What's the best way to catch the session timeout event that is specified during "Create Session" VI?  It appears as if I need a "LV Web Service Request" object to even call the Destroy Session VI, which makes matters much more difficult it seems. Is this even possible?
       
      Thanks for the help
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.