Jump to content
Sign in to follow this  
Manudelavega

Graph cursors displayed against wrong Y-scale

Recommended Posts

Hi,

 

My graph is a XY Graph but the X-scale is just the time. I use the XY Graph in order to define the time stamp of each sample. I use cursors that I snap to the plots in order to display the plots' names. Everything works well when all the plots are displayed against Y-scale 0. But when switching a plot to Y-scale 1, the associated cursor keeps moving like if its plot was still on Y-scale 0. Simply dragging the cursor with the mouse a little bit snaps it to its plot properly (value displayed against Y-scale 1).

 

I tried using the Cursor.YScale property of the cursor but it doesn't seem to help.

 

Has any of you encounter this issue?

 

I am using LV 2011.

 

Thanks!

Share this post


Link to post
Share on other sites

Reproduced on LV2013. See attached VI. Changing the Y-scale of the plot during run-time should reproduce the problem. It seems that the cursor's y-scale is not updated until you move the cursor manually.

 

Reproduce%20Bug.png

 

A workaround is to catch the plot attribute change event and update the cursor list manually. I've implemented this in the attached VI. Enable the Fixit? button and then change the plot's Y-Scale and the cursor should snap to the correct scale.

 

The attached VI is saved back to version 2011. Let me know if it works for you.

 

Ok... I can't attach files... Here it is in dropbox: https://dl.dropboxusercontent.com/u/8640811/XY%20Graph%20Bug/XY%20Graph%20Cursor%20Test.vi

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Porter that looks very promising!

 

I haven't found time to try it inside my code yet but will do very soon and will get back to you.

 

Cheers

Share this post


Link to post
Share on other sites

Just tested it within my code. It works! But what made it work is setting the X-position to 0. I removed the update of the Y-scale property of the cursor and it still works. On the other hand, if I leave the Y-scale property and remove the X-position of the cursor, the fix no longer works.

 

It's strange, I would expect the X-position to be useful in Free mode only, since I use the Index property to specify the point of the plot to snap the cursor to...

 

Anyway, thanks again Porter, this bug had been bothering us for weeks...  :worshippy:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By torekp
      Here is a graph I made recently, which shows particle number (symbol), material (broad color family), measurement location (exact color), amplitude (X axis) and phase (Y axis).  That's five dimensions in a 2D graph!  There are some obvious limitations.  For instance, there are only 16 symbols, so whatever you're representing by choice of symbol better not have more than 16 categories.  And there are only so many colors, especially if you want them all to be ordered in a spectrum from red to violet.  It gets worse when you try to have "broad color family" like I do here with reddish colors for aluminum and bluish for titanium, because the obvious logical thing to do is to skip over some shades in between the families, reducing the total number of available colors.

      What other options should I consider?  How do you do it?  I don't usually use 3D graphs because (a) they're harder to work with and (b) when I create a report for management, they like to have 2D images they can print out, or view without needing Labview on their computer.
      I'm attaching two VIs I use to create color spectra for my graphs.  I use colors_darken_lighten to darken plots for a white background.  To skip over colors, I obtained 6 colors in my spectrum and reshaped the array to two-by-three, then indexed by measurement location to get the first two colors from each broad color family.
       
      colors_darken_lighten.vi
      plot_color_spectrum.vi
    • By Mike King
      Hi, I figured people here may be more interested in this project. 
       
      I have some cool graph extensions I'm building in an open source project, which make some nice graphical overlays for XY graphs and waveform graphs in LabVIEW.  I've got a github page where you can grab the code, support the project or just have a look at some of the same screenshots.
       
      Everything updates live in the graph, so you really need to see it, to get how it all works, so here you go:
      https://github.com/unipsycho/Graph-Extensions-LabVIEW
       
      Please star follow the project if you want to see this developed and I'd appreciate any feedback or ideas to extend it further.  The markers are very much IN development right now, so no where near finished, but the tools can still be seen working.  THANKS!
       


       

    • By codcoder
      Hi guys,
       
      I'm trying to programmatically update the names of five plots in a digital waveform graph. The plots are in a particular order which corresponds neatly withe the order in the legend as in the order under the "Plots" tab in the properties window.
      However when I try to update the Plot.Name property for each plot by stepping through the ActPlot property the order seems to be 1-2-3-4-0, i.e. when I try to change the name of ActPlot=0 it affects the last plot instead of the first.
      What gives? Is there any other indexing property instead of ActPlot I can use which LabVIEW uses to keep track of the plot order? I'm just updating an old vi so it would be nice if it could be solved without altering the waveform used as an input to the graph.
    • By ijustlovemath
      I just recently had a need for XY chart functionality in my application. The example NI has on its website was a little too simple, as I needed support for multiple curves. I've attached the VI and some examples, would love to hear any critiques you have.
       
       
      XYChart.zip
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.