Jump to content

OpenG Toolkit Compatablity Issues


Recommended Posts

Does anyone have any ideas as to why I would be getting the following message while trying to install the OpenG Toolkit through VIPM?

 

post-53830-0-01952100-1438281455.png

 

I'm using LabVIEW 2014 SP1 (32-bit) and Windows 7 Enterprise SP1 (64-bit)

 

Link to post
Share on other sites

What version of VIPM?  If a package is made with VIPM 2014 you have to use 2014 or newer to install it.  2014 added some features that aren't backwards compatible, and don't have a very useful error.  But that being said I wouldn't expect OpenG to be using this newer format.  Can you install the individual packages that library depends on?  

 

OpenG Application Control Library >= 4.0.0.5
OpenG Array Library >= 4.0.0.9
OpenG Boolean Library >= 4.0.0.7
OpenG Buttons Library >= 4.0.0.7
OpenG Comparison Library >= 4.0.0.3
OpenG Dictionary Library >= 4.0.0.4
OpenG Error Library >= 4.0.0.12
OpenG File Library >= 4.0.0.20
OpenG Large File Library >= 4.0.0.3
OpenG LabVIEW Data Library >= 4.0.0.7
OpenG LabVIEW ZIP Library >= 4.0.0
OpenG MD5 Digest Library >= 4.0.0.5
OpenG Message Queue Library >= 4.0.0.15
OpenG Numeric Library >= 4.0.0.5
OpenG Picture Library >= 4.0.0.13
OpenG Port IO >= 4.0.0
OpenG String Library >= 4.0.0.6
OpenG Time Library >= 4.0.0.2
OpenG Variant Configuration File Library >= 4.0.0.5
 
I also see a conflict with these packages, but I would expect VIPM to prompt you saying it will uninstall them if you continue.
 
nilib_rectangle >= 1.2
ogmnu_appcontrol_plus >= 0.3
ogmnu_classic_sync >= 2.5
ogrsc_dynamicpalette >= 0.19
Link to post
Share on other sites

I am using VIPM 2014. I tried to install the OpenG Array Library, and I was able to get that and its dependencies to install. I did notice that the version of the Array library is 4.1.1.14, but the version in the toolkit is 4.0.0.9. This seems to be the case for most of the individual libraries, where the individual version is later than the version called out by the toolkit.

Link to post
Share on other sites

Yeah the original package you couldn't install is just a package that has nothing to it, except a dependency on the other packages.  Sorta like a main release, made up of all the smaller releases.  The new main release isn't made every time a smaller release is made, but instead once a significant number of updates have been made.  It looks like it's been a while since there was a new release, so attached is a VIPC that should contain the updated versions.  Note that the packages themselves are included, so internet is needed to get the packages if they don't exist in your cache already.

OpenG 7-30-15.vipc

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By javier_r
      VIPM.io now allows you to post LabVIEW Resources, Ideas, and Tools. For example, you could post a link to a video tutorial or blog article about a package. You can also post ideas, like feature requests or new tools. Best of all, package developers are notified when you post your ideas and resources, and you can comment and discuss posts with the community. Take a look at this video to learn more: https://www.vipm.io/posts/664960df-f111-4e13-989a-24be8207182d/

    • By javier_r
      Hello everybody!
      Wondering how many people have tried the new vipm.io site. We have added a ton of features to make it easy to Discover LabVIEW Tools and there are some cool ones coming soon.
      Check it out and let me know what you think 😀
       
      Javier

    • By dblk22vball
      I am using the newest version (2020.1) of VIPM, but I had this same issue with the release of 2020.
      For two of the packages that I have created for internal repos, VIPM has decided that I need a System Package.   The posts I have seem from JKI indicate that this is a sub-package that is used internally to the main package, and should be automatically included.
      However, after I am seeing issues on any PC other than the PC where the package was built.
      Is there a setting I am missing?
       
      Showing the (System) package as a dependency:

       
      Package Configuration in the VI Package Configuration Editor
       

       
      Package installed, on the PC where the package was initially created (no issues, no exclamation mark)
       

       

       
      Package when installed on another PC (NOTICE: the System Package name has changed and there is a red exclamation mark, but there are no errors shown on install of the package).

       


    • By ThomasGutzler
      Hi,
      Over night something changed on my windows 10 build server and I can now no longer open VIPM. It just shows the splash screen and then closes again.
      Here's the log file:
      =========== START of VIPM 2018.0.0 (build 2025) Error Message ===========
      An internal VIPM 2018.0.0 (build 2025) Error has occured on: Tuesday August 20, 2019 at 03:19:48 PM
      = Automated Message Start = 
      Error 8 occurred at Open/Create/Replace File in NI_LVConfig.lvlib:Parse Config to 
      Queue.vi->NI_LVConfig.lvlib:Load.vi->NI_LVConfig.lvlib:Open Config Data 
      (compatibility).vi->DDEFA056211BA4DA4D215C322E067D90->621BFCD461979D3C7127139A69154E03->762BBE85A007
      171D5A65B48289D23361->46803A2448FAC5F85BFF8F5C199E9C6F->OGPM 
      Class.lvlib:7D7C5CD8C5D361C01081DF5613237E15->OGPM 
      Class.lvlib:D69AB3997B80ACD75689430E3922612C->OGPM Class.lvlib:OGPM Init.vi->VIPM Splash.vi
      Possible reason(s):
      LabVIEW:  File permission error. You do not have the correct permissions for the file.
      =========================
      DMA hardware error detected.
      C:\ProgramData\JKI\VIPM\cache\ngene_lib_deepltk_fpga_addon-1.0.0.45.spec
      = Automated Message End =
      = User Defined Message Start = 
          Error(s) Generated in Splash Window
      = User Defined Message End =
      = Error Handler Call Chain Start =
          VIPM Splash.vi
      = Error Handler Call Chain End =
      =========== END of VIPM 2018.0.0 (build 2025) Error Message ===========
      Any idea where the files are that it doesn't have the right permissions for?
    • By GregFreeman
      I have been getting some hard crashes in my built application and I have some strange feeling (although it's just a guess) that it is related to a combination of using the database toolkit in a pool of workers that are launched by the start async call node. Their job is to sit there and monitor a directory then parse data files and throw their contents at the database through a stored procedure call. All my hardware comms (2 instruments) are using scpi commands through VISA GPIB and TCP so I think the risk that those are causing crashes is relatively low.
      Active X inside a bunch of parallel threads seems far more risky, even though as far as I can tell adodb should be thread safe, and each thread manages its own, unshared connection. These crashes are happening ~once a day on multiple test stations. I have sent the crash dumps to NI but am waiting to hear back. Right now I am grasping at straws because when I look at the dump file it's pointing me to function calls in the lvrt dll which does nothing for me. 
      I am mostly just looking for any debugging suggestions or direction to getting this resolved more efficiently than just disabling code one loop at a time. I'm also curious if anyone has seen something similar. For the time being, I have reduced my number of workers to 1 in case it is a thread safety issue. I have also considered getting rid of that DB toolkit and leveraging .NET, even though I think that is just a wrapper around the same calls. Looking inside the database toolkit VIs alone scares me.
      FWIW I am using LabVIEW 2013 in this application.
      Thanks!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.