Jump to content
jsettles

OpenG Toolkit Compatablity Issues

Recommended Posts

Does anyone have any ideas as to why I would be getting the following message while trying to install the OpenG Toolkit through VIPM?

 

post-53830-0-01952100-1438281455.png

 

I'm using LabVIEW 2014 SP1 (32-bit) and Windows 7 Enterprise SP1 (64-bit)

 

Share this post


Link to post
Share on other sites

What version of VIPM?  If a package is made with VIPM 2014 you have to use 2014 or newer to install it.  2014 added some features that aren't backwards compatible, and don't have a very useful error.  But that being said I wouldn't expect OpenG to be using this newer format.  Can you install the individual packages that library depends on?  

 

OpenG Application Control Library >= 4.0.0.5
OpenG Array Library >= 4.0.0.9
OpenG Boolean Library >= 4.0.0.7
OpenG Buttons Library >= 4.0.0.7
OpenG Comparison Library >= 4.0.0.3
OpenG Dictionary Library >= 4.0.0.4
OpenG Error Library >= 4.0.0.12
OpenG File Library >= 4.0.0.20
OpenG Large File Library >= 4.0.0.3
OpenG LabVIEW Data Library >= 4.0.0.7
OpenG LabVIEW ZIP Library >= 4.0.0
OpenG MD5 Digest Library >= 4.0.0.5
OpenG Message Queue Library >= 4.0.0.15
OpenG Numeric Library >= 4.0.0.5
OpenG Picture Library >= 4.0.0.13
OpenG Port IO >= 4.0.0
OpenG String Library >= 4.0.0.6
OpenG Time Library >= 4.0.0.2
OpenG Variant Configuration File Library >= 4.0.0.5
 
I also see a conflict with these packages, but I would expect VIPM to prompt you saying it will uninstall them if you continue.
 
nilib_rectangle >= 1.2
ogmnu_appcontrol_plus >= 0.3
ogmnu_classic_sync >= 2.5
ogrsc_dynamicpalette >= 0.19

Share this post


Link to post
Share on other sites

I am using VIPM 2014. I tried to install the OpenG Array Library, and I was able to get that and its dependencies to install. I did notice that the version of the Array library is 4.1.1.14, but the version in the toolkit is 4.0.0.9. This seems to be the case for most of the individual libraries, where the individual version is later than the version called out by the toolkit.

Share this post


Link to post
Share on other sites

Yeah the original package you couldn't install is just a package that has nothing to it, except a dependency on the other packages.  Sorta like a main release, made up of all the smaller releases.  The new main release isn't made every time a smaller release is made, but instead once a significant number of updates have been made.  It looks like it's been a while since there was a new release, so attached is a VIPC that should contain the updated versions.  Note that the packages themselves are included, so internet is needed to get the packages if they don't exist in your cache already.

OpenG 7-30-15.vipc

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.