Jump to content

LabVIEW on Intel NUC


Recommended Posts


When I try to install LabVIEW 8.5.1 runtime or visa 4.1 on an Intel NUC with CPU i5 7260U I get:

Microsoft Visual C++ Runtime Library

Runtime Error!

Program ........\LV RunTime 8.5.1\setup.exe

This application has requested the Runtime to terminate it in 

an unusual way.

Please contact the application's support team for more 



Just in case I installed Visual C++ 2005 redistribution and checked under add remove programs that the Windows feature of allowing version under .net 3.5 to run was enabled.

This is not an ARM based processor so why does LabVIEW has a problem installing on the NUC?

Link to comment

I have 8.5.1 runtime running on win10.

The fact you can run it on a U processor tailored for mobile says I guess that the issue is not the processor but rather some other NUC issue or C++ issue.

Did someone here install LV on a NUC?

Link to comment

My NUC is running Win10 64 bit  and I installed all the updates.

The KB offers patches for win8.1, 8, vista, RT, server8 and server 2012 assuming that the issue is solved for win10 through the updates.

Should I try installing the win 8.1 64 bit patch on my win10 64bit?

Link to comment

8.5 came out in 2007 and 8.2 in 2006, so they and their installer may or may not be built in Visual Studio 2005. There is a good change that they were in fact created using Visual Studio .Net 2003 or even Visual Studio .Net 2002 though that last one doesn't make to much sense as it was pretty flaky. So you may need to specifically add support for the Visual Studio 2003  C runtime library to your system. Starting with Visual Studio 2002 Microsoft deviated from the previous principle that all Microsoft C compiled programs were referencing the standard MSVCRT.dll that was also part of the Windows installed components. Instead each created application was using its own version of the C runtime library depending on the Visual C version used. Those C runtime versions often are installed in a standard Windows installation as many components that are distributed with Windows were created with various versions of Microsoft C (some pretty old). But it is very feasible to assume that Microsoft managed to extinguish in Windows 10 any application that still requires a C runtime library version prior to 2008.

It may still be present on a fresh install of Windows 10 sometimes, depending on additional installs like video or network card drivers for instance with their own specific utilities, but it is very likely that it does not come with any Visual C 2005 support or earlier. Unfortunately it is pretty much impossible to convince Visual C to not use the version specific C runtime library. Writing a new C compiler is almost easier :D. The installer will of course install the C runtime library support that LabVIEW 8.2 or 8.5 will need, but in order to install the C runtime library support for the installer itself you would need an installer for the installer. A sure catch 22 situation.

Only applications created in Visual Studio 6 can run on any Windows version without needing specific C runtime versions to be installed. But I'm sure Microsoft is considering ways to break that at some point :lol:

Edited by rolfk
Link to comment

No no. Gnu C on Windows has no significant use. You might need it if you use one of the Open Source C compilers such as DevC or or MinGW or Cygwin, which are based on gcc but Visual Studio is based on Microsoft Visual C and will never use the GNU C library! :lol:


It might work with the Visual Studio 2003 runtime installer but there is no 64 bit version for that. Visual Studio 2005 was the first version to properly support creating 64 bit applications. If it works depends on what Visual Studio version was used to create the installer executable. You shouldn't need to install the entire Visual Studio software, just the redistributable Visual C runtime library for the correct Visual Studio version.


Edited by rolfk
Link to comment


I installed:

1. .net 1.1 (via slipstreaming)

2. visual studio .net 2003 full application (took me forever to find it)

However. LV 8.5.1 runtime keeps giving a C++ runtime error.

I went into the unpacked installer of LV 8.5.1 and found the MSI installer of the LV8.5.1 and it did run!

Not all the MSIs of the packages run. Some report a missing Microsoft component.

My app opens and hangs now which is a different behavior than before.

Visual Studio SP1 patch still can't run saying that Visual Studio itself is not installed. How do I install the runtime now that I have the IDE? I can't find the runtime.



After nstalling VS2003 IDE the VS2003 SP1 was able to run, thus, I have VS2003 runtime and .net 1.1 yet LV 8.5.1 still fails on C++ error.

The runtime MSI was able to run successfully yet I don't see National Instruments in add remove apps or the LV 8.5.1 runtime itself which is strange. 

My app still doesn't run on the NUC with Win10 64bit

Edited by 0_o
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.