Jump to content
jgcode

[LVTN] LVOOP Assistant

Recommended Posts

ok, here are two pics showing the behaviour

The old class seems to use a big font, but when I use the assistant on a newer class, even if I type the same text it uses a smaller font.

Yes, the reason for that is as explained above.

10-pt would still 'fit' if you always less characters.

Another thing. Don't know if this is related to the LVOOP Assistant or not, but it happened shortly after installing it. Once, when I went to the Class properties dialogue I got a bunch of LV errors and none of the sub-pages loaded properly. The errors were not fatal, and selecting the Properties again caused it to work fine. This has only happened to me once, and I have only been using 2010 for a few weeks now. Will keep you posted if it happens again and try and make a note/screencap of the error messages.

(Are you using the LECC2010 version - v0.16?)

Hmm, I saw this once too, but never with LV 2009, only in LV2010. And like you said it was fine after reloading. I can't seem to replicate it, but will have to keep an eye out.

If anyone has any info on this or seen anything similar before when working with Classes + scripting, please post

Share this post


Link to post
Share on other sites

I uploaded a new version to LAVA - the main feature is native support for LabVIEW 2010.

The code now checks for LabVIEW version and mass compiles if IDE is newer.

I tried to optimize it as just compiling the directory takes a long time due to a few Libraries and Classes etc...

The workflow is pretty much copied from what I have seen using some JKI tools - so props to them.

post-10325-0-16923500-1295715684_thumb.p

post-10325-0-23593900-1295715809_thumb.p

Notes:

  • Version 0.16 was entered in the LECC 2010 but was not added to the LAVACR.
  • Version 0.17 just updates some support files for LAVA and is added to the LAVACR.

Cheers

-JG

Version History (Changelist):

0.17-1 2011 01 23

- Changed (): Rebuild for LAVA distribution. Support files changed only (no code changes).

0.16-1 2010 10 05 (LabVIEW Example Code Contest 2010)

- Added (): Support for LabVIEW 2010. Include Mass Compile option on first load

- Changed (): Now requires Icon Editor API v2.1-1 as dependency

- Fixed (): Popup on New Class Control resolves correct 'Current Icon'

Share this post


Link to post
Share on other sites

The code now checks for LabVIEW version and mass compiles if IDE is newer.

Actually this is not required anymore since VIPM 2010 already does a mass compile after installing packages now.

Share this post


Link to post
Share on other sites

Actually this is not required anymore since VIPM 2010 already does a mass compile after installing packages now.

Yes, that is correct however, for a normal VIs this is great.

For a larger dist with libraries and class I found it was much slower.

The reason being that all code in the directory was handled i.e. open/checked/compiled.

But due to the above VI relationships this was slow.

What I did to optimise it was to only point to a VI Tree so one VI gets handled.

I don't have any benchmarks recorded but it was actually something I wanted to discuss with you.

Share this post


Link to post
Share on other sites

Yes, that is correct however, for a normal VIs this is great.

For a larger dist with libraries and class I found it was much slower.

The reason being that all code in the directory was handled i.e. open/checked/compiled.

But due to the above VI relationships this was slow.

What I did to optimise it was to only point to a VI Tree so one VI gets handled.

I don't have any benchmarks recorded but it was actually something I wanted to discuss with you.

I don't know how the JKI install works, but you are right.

You only need to compile the hierarchy from the top level VI (which is what your VI tree is doing) rather than compile every VI..

I scan all VI's and see if they have any parents (lone VI's - these will be the top level VIs) then compile "Entire Hierarchy" only for those VIs and just save all the dependants. Opening a reference is quick, but compiling isn't. The advantage of this method is that you don't need a VI Tree VI (so it's more generic) and, for a couple of hundred VI's you only end up compiling a small subset and the compilation process is smart enough that shared VI's that are already compiled and/or saved are skipped (or so it seems)

It's no really an issue in 2009 because it's all very quick. But 2010 is such a slug (installing SQLite API in 2009 takes about 20 seconds. In 2010 it's about 1 minute i.e 3x slower)

Edited by ShaunR
  • Like 1

Share this post


Link to post
Share on other sites

Yer, Tom let me know about the change he made to PPL in 2011. I think the 2011 Icon Editor API has now been posted. I am away at the moment but will check DL 2011 and check it out when I fly home.

In the meantime, the LVOOP Assistant is not compatible with 2011 - but I guess what you get for using unsupported features. I would love to see the API officially released:

http://forums.ni.com/t5/LabVIEW-Idea-Exchange/Icon-Editor-API/idi-p/1141247

Vote for this Idea to help out :)

Share this post


Link to post
Share on other sites

I have added a new version to the LAVA-CR - v1.0.0.23

post-10325-0-25492500-1330269971_thumb.p

This version supports LabVIEW 2011 and integrates into the LabVIEW Project Provider API

The previous version was broken in 2011 as the Icon Editor API was not supported due to a switch to PPL 2011, so this functionality will not be included at the moment.

I started playing around with the Provider API with Create Child Class which was a good plugin to start with.

Along the way I found out that there was a limitation preventing me from releasing individual packages under one 'banner' so I will just be upgrading this package with new functionality in the future.

And therefore won't be updating the Create Child Class package I posted - it will be done in this package.

I've also moved the Rename LVOOP Labels code into this package as it more intuitive to use with the Provider.

I need to brush up some stuff (examples etc...) but it this package is ready for feedback so please post :)

So, in summary v1.0.0.23 supports:

  • Rename LVOOP Labels
  • Create Child Class
  • Clone Method

Right-click on a Class or Class Method VI to access the plugins:

post-10325-0-76596300-1330270136.png

Go to Tools>>LVOOP Assistant to access other stuff:

post-10325-0-07820900-1330270092.png

It also uses the Preferences code I OpenG'd up :)

post-10325-0-45954900-1330271231_thumb.p

Enjoy!

Share this post


Link to post
Share on other sites

I have added a new version to the LAVA-CR - v1.1.0.39 which contains the following new features:

- New (): Added 'New Templates' feature

- New (): Added 'Methods Sandbox' feature

- New (): Added 'Refresh Icon' feature

There are now in built templates I use - you can pop-up on a Class and select New Template to add a template to that Class

If there are other common templates, please post and I can look at adding them

post-10325-0-35211500-1330446101.png

By placing your own templates in the Templates Folder...

post-10325-0-61386500-1330446103.png

post-10325-0-09803700-1330446096.png

...You can script new Class Methods with them

Pop up on a Class and select Methods Sandbox

This UI will allow you to quickly script either the inbuilt or custom templates to create new Methods:

post-10325-0-70419300-1330446097_thumb.p

The last feature allows you to pop up on a Class Method to quickly refresh a Method's icon without having to open the Class Properties Dialog and refresh all icons

post-10325-0-16668600-1330446102.png

Share this post


Link to post
Share on other sites

Hey Jon... you coming back to Labview or just stopping by for a visit?

  • Like 2

Share this post


Link to post
Share on other sites
Hey Jon... you coming back to Labview or just stopping by for a visit?

 

On secondment? Lol

  • Like 1

Share this post


Link to post
Share on other sites

Hi!  Relative LVOOP newbie.  I last used LV back in 1997 or so and am now getting back into it.  I'm trying to install LVOOP Assistant in LV 2014.  I downloaded what appeared to be the latest version (lava_rsc_lvoop_assistant-12.1.0.138.vip) and ran VI package manager, got the mass-compile, etc... but I can't find the right-click menu anywhere.  Right-clicking on classes, methods, etc in the Project Explorer, I don't see the LVOOP menu.

 

Any ideas?

 

Thanks,

-Jamie


Never mind.. I restarted and now I see it.  I thought the restarting that occurred during installation was sufficient but I was mistaken.  Sorry, n00b :-)

Share this post


Link to post
Share on other sites

Hi there!

First of all, thank you so much for the awesome work! :D

 

I have a small question that I'm hoping you can shed some light on; I installed the latest version of the LVOOP assistant, and I wanted to use the quickdrop shortcuts for the Theme Editor, but can't seem to find them in the documentation; do I need to set them up manually? 

 

Thanks again and have a great day! :)

Share this post


Link to post
Share on other sites

I realize this topic hasn't been touched for a few years, and if something better than the LVOOP Assistant exists, I'd be happy to hear about it. The GOOP suite is nice, but handles member VI icons poorly, I just wanted something to change the color theme, which is how I found this.

Anyway, I don't know if this is a problem introduced with newer versions of LabVIEW since this was last updated, but any change I make to member VI icons through the theme editor or the library icon viewer does not force a save of the VIs of a class. The functionality works, but I can close the entire class, reopen it, and see the old VI icons. It doesn't prompt me to save them when closing and doesn't show an asterisk in the title bar of any VIs.

I haven't found a way to save all the VIs in a class after changing icons outside of opening each one individually and saving it. Doing a save all or right clicking on the class and choosing save all (this class) don't work.

Did this work previously? Is there any chance of it being looked into at this point?

Share this post


Link to post
Share on other sites

If you want to simply change class banner color, check this:

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.