Jump to content

Create a project template on Labview enviroment


Recommended Posts

Thank you for the prompt reply. I read the post you have suggested to read, even though that post is very intersting it is not what I would like to do, I would like to build a new project, create on the project some virtual folders (the virtual folders I always create on my projects) and then I would like to save it as template. Therefore it will be very easy to create a new project starting from that template with the virtual folder I usually create on every project I do.

(I hope it was clear) Do you think it is possible to do that?

Regards.

Link to comment
I would like to build a new project, create on the project some virtual folders (the virtual folders I always create on my projects) and then I would like to save it as template.

If I understand correctly what you are asking...

There is no such thing as a .lvproj template but why not just create the above .lvproj file once then every time you want it, copy it manually, or write some simple tool to make a copy of it?

Link to comment

This is a very nice trick, but I do not want to copy every VIs I've created on a different project, I just want a template which allows me to have an entry point to build my new project and which creates the structure which usually I use on every project I want to develop. I think the suggestion of JCODE is a good advise the only thing which is missing is that you can't call the template from the "New window" which is opened when you click on the New menu under the File menu of labview....

Link to comment

...the only thing which is missing is that you can't call the template from the "New window" which is opened when you click on the New menu under the File menu of labview....

No, but you can install the tool under <wizard> or <project> yourself and get the same effect.

Link to comment
  • 10 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By etgohomeok
      Hello, this is not strictly VI Scripting related but I believe it's a pretty similar topic, so I hope this fits in with the discussion on this board.
      I am attempting to write a script that parses through the contents of a very large LabVIEW project (thousands of files) recursively and selectively moves/renames some of the files. The basics of this are fairly simple, however I have thus far been unable to come up with a way of moving files on disk that handles all relinking and dependencies without any issues.
      At a high-level, my question is whether or not the "Move on Disk..." option in the right-click menu of the project explorer "Files" view is accessible programmatically somehow, using invoke nodes. The option I'm talking about, for clarification, is this one:

      Using this option in the project explorer seems to be able to move all types of files in the project (VIs, libraries, classes, etc.) and handle all relinking properly without any conflicts popping up. However, there doesn't seem to be an equivalent "Move on Disk" method int he invoke node for project items. I have had some success with some of the "super secret" nodes for VIs:

      However this only works for VIs and there is no equivalent function for library (.lvlib) and class (.lvclass) files. I've tried various combinations of saving and relinking functions that are available, however I always end up with conflicts when I load the project after running my script.
      If the "Move on Disk..." function is not accessible programmatically, does anyone know of another way to programmatically move/rename library and class files on disk without causing conflicts?
      Thanks,
      Ethan
    • By 0_o
      A power failure crashed my LabVIEW before I pushed some important work to the repository.
      Recover seemed to work yet I got a message saying that the vi can't be saved and it was actually corrupted:
      "Cannot load diagram of "....vi""  and the only option is "cancel save".
      Regular cut and paste tricks didn't work and before starting to go over the Hex code I tried something that I didn't see anyone write about and it worked so here it goes for those future corruption fighters (I can't promise it will work each time though):
      The VI was written in LV 2011. I tried opening a new vi by using the still opened corrupted vi as a template.
      It didn't work.
      I moved up to LV 2013 and it still didn't work.
      Trying the same with LV 2014 did the magic.
      All that was left to do is to save to previous version (LV 2011) and correct the file's location and name.
      Done. 
    • By HelenaDomo
      Hi all,

      We are a group of students from the University of Cambridge who are developing a new data connectivity system for researchers like us, its up at https://rinocloud.com

      It currently integrates with LabVIEW, Matlab and Python. The plugin will point your data directly at our secure storage where you can automatically add metadata results for easy and fast retrieval. We’re also rolling out plotting features for presenting the data, collaboration features for project teams and an integrated lab book.

      We are looking for new users, researchers like us, to help us to get feedback from our product.  You’ll be able to directly influence the product development so that you get a data system that is useful for you.

      Know more at https://rinocloud.com 
      https://twitter.com/Rinocloud
       
      Thanks, 
      Helena
    • By koushik
      Hello,
        I have set up a vi in my project where it deploys startup.rtexe, web service and the related web service vi and a shared variable library to the real-time(sbRIO) target. i have 3 targets in the project 1) My computer 2) RT-Target 3) FPGA.
       
        What i want is to change the properties of the RT-Target whereby i can assign the IP address of the device to the target project properties programmatically. i can manually assign the IP address by right click on target->properties->IP address. but sometimes the IP address changes and so target cannot be reached and deployment fails. i want to be able to set the IP address through the VI and then deploy the items to the target. 
        Please suggest a way to do this.
      Thank you.
    • By John Lokanis
      I am seeing some strange behavior each time I open a certain project in LV2013.  For some reason a VI I was working on recently always opens its front panel when the project is opened.  And it shows a broken arrow for a few seconds while the cursor is in a busy state.  Then, the arrow changes to unbroken.  I close the VI, I do a save all (and LV saves 66 VIs for some reason) and then I close the project.  When I reopen the project, it does the exact same thing.
       
      Has anyone see this type of behavior before?  Is this due to something I did or is it a bug?  Any fixes/workarounds?
       
      i have not contacted NI yet since this could be my fault and it only happens with a certain project and only recently (I have been using LV2013 for awhile now without this issue).
       
      thanks for your input.
       
      -John
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.