Jump to content
RnDMonkey

Intended OpenG installation and update flow?

Recommended Posts

I see in VIPM that there is the OpenG Toolkit, then the individual packages as well. Is the intent to install the OpenG Toolkit (assuming you want all the modules) package, then update the individual modules as they are updated? I feel safe in assuming that *since I've already installed all the individual packages that there is nothing for me to be bothered about, if I am correct in assuming that the "OpenG Toolkit" package is just a snapshot of a major release or when the appropriate person feels like updating the snapshot.

 

Ryan R.

Edited by RnDMonkey

Share this post


Link to post
Share on other sites

Hey Ryan.  Yes, that's right. The main OpenG Toolkit is just a simple way to install everything. There's actually nothing in the package itself -- it just declares dependencies on all the individual packages.

Share this post


Link to post
Share on other sites
Hey Ryan.  Yes, that's right. The main OpenG Toolkit is just a simple way to install everything. There's actually nothing in the package itself -- it just declares dependencies on all the individual packages.

I wondered how that worked, that's neat.  I for some reason always thought it was all the packages in one, so I never installed it because I was worried I would have two versions of OpenG installed on my palette if I did.  Thanks for the info.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By GregFreeman
      I have been getting some hard crashes in my built application and I have some strange feeling (although it's just a guess) that it is related to a combination of using the database toolkit in a pool of workers that are launched by the start async call node. Their job is to sit there and monitor a directory then parse data files and throw their contents at the database through a stored procedure call. All my hardware comms (2 instruments) are using scpi commands through VISA GPIB and TCP so I think the risk that those are causing crashes is relatively low.
      Active X inside a bunch of parallel threads seems far more risky, even though as far as I can tell adodb should be thread safe, and each thread manages its own, unshared connection. These crashes are happening ~once a day on multiple test stations. I have sent the crash dumps to NI but am waiting to hear back. Right now I am grasping at straws because when I look at the dump file it's pointing me to function calls in the lvrt dll which does nothing for me. 
      I am mostly just looking for any debugging suggestions or direction to getting this resolved more efficiently than just disabling code one loop at a time. I'm also curious if anyone has seen something similar. For the time being, I have reduced my number of workers to 1 in case it is a thread safety issue. I have also considered getting rid of that DB toolkit and leveraging .NET, even though I think that is just a wrapper around the same calls. Looking inside the database toolkit VIs alone scares me.
      FWIW I am using LabVIEW 2013 in this application.
      Thanks!
       
    • By Tomi Maila
      At JKI, we have found that a professional user interface design can make a huge difference for LabVIEW applications. That’s why we’re very proud to announce we have just released the JKI Flat UI Controls for LabVIEW, a beautiful, professionally-designed set of LabVIEW controls that we use on some of our own projects at JKI!  We hope that by sharing these with the community, we can help make it easy for just about anyone to build their own beautiful and intuitive user interfaces in LabVIEW.
       
      Learn More & Download 

    • By gmiles
      https://m.youtube.com/watch?v=v6X4QkYQTZU&feature=youtu.be
    • By _Y_
      We use USB-connected Microsoft Smart Card Reader. The devise crashes sometimes. It does not happen often thus search for the reason could take time.
      The only way to get the devise functioning again, is to open Device Manager, click Uninstall then Scan for hardware changes (that installs the Reader again).
      Is there any method to do this from LabVIEW? I.e. send commands to reinstall the USB device?
      I know this could be a bad fix. However, it can help in long-time tests (while we are searching for reason of these crushes).
      Thank you
    • By ShaunR
      LVA-Tools.Co.Uk is having a Post NI Week Bonanza with 40% off all commercial toolkits..
      Offer is available for one week so grab the opportunity to secure your business data and websocket that application.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.